OS9上のQX3.3がフォントを認識しない(メジャーパレット、フォント置き換えともに)

OS9、QuarkXpress3.3で、文字中心のページもの(モノクロA5判で200P程度)をつくっているとき、メジャーパレット上でフォントを選ぼうとすると「ー」とでて、フォントが出なくなり、メニュー画面からも含めて、フォントが出なくなり、選択できなくなりました。ファイルが破損したのかと思い、隣にあるMAC(同じ環境)にあるver.4.1で開いてみたところ、「不明なフォントあり」とのメッセージが出てきました。そこでとりあえず「リュウミン」などを指定して置き換えてしまおうとしても、その置き換えウィンドウでもフォントが出てこなくなりました。MACを再起動して、他のファイルを開いてもその問題はおきません。特定のファイルのみにおこります。隣のMACには同じくver.3.3も入っていますが、このMACでは症状はおきません。どちらのMACにも、モリサワのNewCIDをいれています。

ただ、通常の編集作業は問題なくできます。画像の配置や文字入力もできます。PSプリンタでの出力も問題なくできます。また、正常なQXファイルを開いて、そこのメジャーパレットからフォント名をコピーして、問題のあるファイルのメジャーパレット上(「ー」表示されているところ)にペーストしてみると、なんとフォントはちゃんとかわります。なので、以前、印刷所データ入れ直前にこの症状が出たとき、ほぼ出来上がり状態だったので、そうやってフォントはいじり、印刷だけちゃんとして、急遽、版下入稿という手段で、しのぎました。ひょっとしてそのままデータ入稿しても問題ないかとも思いましたが、迷惑がかかるのでやめました。

ちなみに、この症状はいつも起きるわけではないので、普段は困ることはありません。ただ、全く同じ症状ではないのですが、以前、同じくモノクロページ物をやっていたときに、メジャーパレットでのフォント選択の際、フォントがずらーっとでるはずのポップアップで、真っ白になり、同じくフォントを選択できないという症状が出たことがありました。そのときは、MACを再起動しても同じ症状になりつづけました。隣の機械にデータをうつし、ver.3.3で開いたところ問題なく作業続行。翌日、元の機械に戻してみたところ、元通りにもどっていました。それ以後はその症状は出ていません。同じくフォントに絡む問題だったので、リンクするのかなと考えています。

隣のMACでは起きないということから、OSなどの問題なのか、何かの設定の違いなのかと考えているところです。いずれにしても、アプリケーションの内部ではちゃんとフォントを認識しているので、インターフェイス上にはでてこないということでしょうか。MACのリストアも計画してはいますが、フォントのFD交換とかも発生しますし、また同じことがおきると痛いので、何か原因がわかればと思った次第です。同じような症状が出た方など、ご教授ください。3.3をもうやめろというならそうしようとも思います。よろしくお願いします。
» 001
こんばんは。masa@dです。
「不明なフォントあり」との事ですが、
スタイルシートの中に不明なフォントが
あるような気がします。

ドキュメントで使用せずに、
スタイルシートのみに不明なフォントが
ありますと、フォントの検索置換では
表示されないようです。

該当するマシンのクォークでドキュメントを開いて、
スタイルシートの確認をしてみてはいかがでしょうか?

警告無しで開けるマシンでも
同様に確認してみると、
スタイルシート部分の違いが
分かるかも知れません。

ご参考までに。
» 002
masa@d様

早速ありがとうございます。
不明フォントについてのエラーは以下のものでした。

6295,不明
-3,不明
-10004,不明
-4,不明

スタイルシートについて調べました。すると見たこともないスタイルシートが一つありました。どうも他のファイルから本文を持ってきたときに一緒にきたようです。その元のファイルが破損していたのかもしれませんね。

ただ、前から不思議なのが、たまに他人からもらうファイルに、上記のようなフォントエラーが出ていることがよくあります。展開するときにエラーが出ると、特殊なフォントにまずは置き換えて、開いた後でそれがでていれば目で確認して直すといったことをしています。